MicroStation

Job Submission

You can submit jobs from within MicroStation by installing the integrated submission script, or you can submit them from the Deadline Monitor. The instructions for installing the integrated submission script can be found further down this page.

integrated monitor

To submit from within MicroStation (once the submitter has been installed), navigate to the Utilities->Render menu and select ‘Submit To Deadline’. Alternatively, you can use the Key-In ‘mdl load DLSubmit’ to bring up the submission UI (or ‘dlsubmit open’, once it’s already been loaded).

ms_menu ms_keyin

Submission Options

The general Deadline options are explained in the Job Submission documentation. The MicroStation-specific options are:

  • Operation: This is the type of MicroStation operation that will be performed by the Deadline Job. The different options are described below:

    • Animation Render: This will render the currently active Animation Script through Deadline.
    • Single View Render: This will render a single view as an image through Deadline.
    • Save Multiple Images: This will submit the currently active “Save Multiple Images” script as a Deadline Job, or use the specified SM file.
    • File Export: This will perform a File->Export operation as a Deadline Job (only a specific subset of these operations are currently available).
    • Print: This will perform a Print operation as a Deadline Job using the current settings, or the specified PSET file.
  • Mode: This option is dependent on the type of Operation selected. Will either specify the Render Mode, or type of File Export to perform.

  • Color Model: This drop-down allows you to select the Color output of the Render (e.g. full RGB, GrayScale, MonoChrome, etc.)

  • Design File: This option is only relevant to the Monitor Submitter, and specifies which Design File to use for the selected operation. For the integrated Submitter, this will always be the DGN file that is currently open.

  • Submit Files with Job: This option, if checked, will submit files with the job, as opposed to leaving them in their current location.

  • View Number: The number of the Viewport that will be used for rendering (1-8).

  • View Name: (Optional) The name of the Saved View that will be applied before rendering.

  • Output Size X: The X (horizontal) component of the output size. Set to 0 to use current value, or maintain Aspect Ratio (depending on whether or not the Aspect is currently locked).

  • Output Size Y: The Y (vertical) component of the output size. Set to 0 to use current value, or maintain Aspect Ratio (depending on whether or not the Aspect is currently locked).

  • Environment: The name of the Environment to use for Luxology Renders. If the specified Environment is not found, the Untitled setup will be used.

  • Render Setup: The name of the Render Setup to use for Luxology Renders. If the specified Render Setup is not found, the Untitled setup will be used.

  • Frame List: The list of Frames to render during Animation Renders.

  • Task Size: The number of Frames (Animation) or Script Entries (Save Multiple Images) to process per Deadline Task.

  • Settings File: The path to an operation-specific file that will specify additional settings for the operation (e.g. Print Settings file, DWG Export settings, etc.).

  • Use Current Settings: This checkbox is only available from the integrated submitter. If checked, a new settings file will be created and submitted with the Job, based on the settings in the current MicroStation session.

  • Output Path: The Path to the output that will be created. Frame padding should be represented by either ‘#’s or ‘0’s. Unrecognized file formats for the current operation will be changed to a default known format at render time.

  • Convert Network Paths to UNC: If this option is selected, Deadline will attempt to convert paths from using Mapped Network Drives to using the full UNC network path.

Note that some of these parameters might not apply to all Operations/Modes. The Submitters will automatically disable or hide controls that are not relevant to the currently chosen Operation/Mode.

Plug-in Configuration

You can configure the MicroStation plug-in settings from the Monitor. While in super user mode, select Tools -> Configure Plugins and select the MicroStation plug-in from the list on the left.

../_images/microstation_plugin.png

MicroStation Executables

This section defines the possible locations for ustation.exe for different versions of MicroStation. The Deadline Slaves will look for the executable in each of these locations (in order) when it tries to render a MicroStation job.

Integrated Submission Script Setup

The following procedures describe how to install the integrated MicroStation submission script. This script enables MicroStation jobs to be submitted to Deadline directly from the MicroStation GUI. The following procedure has been tested in MicroStation v8i SS3 (08.11.09).

Submitter Installer

Manual Installation of the Submission Script

First, copy the following files to your [MicroStation install]\mdlapps directory:
  • [Repository]\submission\MicroStation\Client\DLSubmit.dll
  • [Repository]\submission\MicroStation\Client\TBUtils.dll
  • [Repository]\submission\MicroStation\Client\TBUtils.ma
  • [Repository]\submission\MicroStation\Client\Thinkbox.Common.dll

where [MicroStation install] directory would be typically something like: “C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation”.

This should allow you to use the MDL KeyIn “mdl load DLSUBMIT” to load the Deadline Submitter within the MicroStation GUI.

If you want to have a menu item to Submit to Deadline, you can append the file path [Repository]\submission\MicroStation\Client\DeadlineMenu.dgnlib to your MS_GUIDGNLIBLIST configuration variable (under ‘Workspace’ -> ‘Configuration...’ in MicroStation), or you can manually create your own menu item in a custom DGNLIB by following these instructions from Bentley.

NOTE, the MicroStation Submitter Installer, will by default, install the “DeadlineMenu.dgnlib” file to this location: “C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace\Interfaces\MicroStation\default” which may be preferred instead of pointing all MicroStation machines to use the copy that is stored on the Deadline Repository. If you use the “MicroStation Submitter Installer” approach, note that it is NOT necessary to edit the MS_GUIDGNLIBLIST configuration variable.

ms_ui_config ms_ui_guiconfig

Sticky and Default Settings

The integrated MicroStation submitter has a feature that saves previously selected values for specific controls as Custom Properties in the design file that was used for submission, so that they can be restored automatically for future submissions.

The list of controls that are flagged to have “sticky” values is determined by the MicroStation_StickySettings.ini file in the submission/MicroStation/Main folder of your repository. In addition to this, there is also a MicroStation_DefaultSettings.ini file alongside it, which will control the Default values for all controls, when there are no sticky settings present/enabled. These files can be freely modified to fit your needs, but keep in mind that any changes made will affect all users.

The priority of setting values is as follows:
  1. Sticky Settings: For a given control, if there is a sticky value present in the scene file, it will be used first if the control is flagged as sticky in MicroStation_StickySettings.ini.
  2. Default Settings: For a given control, if a (valid) default value is provided in MicroStation_DefaultSettings.ini, it will then be used.
  3. Factory Defaults: If neither of the above are present, hardcoded defaults are provided. These cannot be changed.

Note that if any Sticky or Default value is invalid for any reason (e.g. a sticky Saved View was deleted), the control will fall back to the next level of default.

FAQ

Is MicroStation supported by Deadline?

Yes.

Which versions of MicroStation are supported?

Currently, only MicroStation v8i SS3 (08.11.09) is officially supported. We will look to support different versions of MicroStation as they come out in the future, or as demand dictates.

Does the MicroStation plugin support Tile Rendering?

Not currently. The plan is to investigate the possibility of including this feature in MicroStation going forward.

How do I remove the multiple entries of the “Submit to Deadline” menu entry in MicroStation GUI?

Please ensure you do NOT store the “DeadlineMenu.dgnlib” file in this location on your local machine: “C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace\Interfaces\MicroStation\default”. The only place the “DeadlineMenu.dgnlib” file should be declared is in the MS_GUIDGNLIBLIST configuration variable and it should make reference to the file from the Deadline repository network path.

Do I need a “DeadlineSubmission.dll” file in my [MicroStation install]\mdlapps directory?

No. This is an old version which is now deprecated. Ensure you only have the files which are identified above in the “Integrated Submission Script Setup” section as copied over to your \mdlapps directory. Ensure you either use the “DeadlineMenu.dgnlib” UI configuration method described above or the manual MDL KeyIn method to start the Deadline Submission UI: “mdl load DLSUBMIT”.

Error Messages and Meanings

This is a collection of known MicroStation error messages and their meanings, as well as possible solutions. We want to keep this list as up to date as possible, so if you run into an error message that isn’t listed here, please email Deadline Support and let us know.

Currently, no error messages have been reported for this plug-in.